Get in touch
Back
Maintenance

Hosted bittorrent tracker maintenance

Completed 9 Oct at 02:43pm PDT.

Test Runner
Completed

Maintenance completed

Posted 9 Oct at 02:43pm PDT.
Started

We're deploying updates to our hosted bittorrent tracker. Peers used in the bittorrent challenge will be unavailable for a short while.

Posted 9 Oct at 02:43pm PDT.