Get in touch
Back
Maintenance

Hosted bittorrent tracker maintenance

Completed 17 Sep at 10:10am PDT.

Test Runner
Completed

Maintenance completed

Posted 17 Sep at 10:10am PDT.
Started

Our hosted bittorrent tracker will be undergoing maintenance for roughly 30 minutes.

Other challenges are not affected.

Posted 17 Sep at 09:47am PDT.